Audio Mixing Platform (AMP)

Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: New host crashes out  (Read 1876 times)

mattseymour

  • Guest
New host crashes out
« on: June 10, 2018, 11:33:05 AM »

As well as my gui woes, playing with the new host on my laptop (just a quick test) and I can't get it to play ball with my cheapy behringer USB interface. It initially connects to the ASIO driver before crashing out.

I'm wondering with these two problems if there's a runtime issue following some windows 10 updates.

Happy to do any testing that might be useful.
Logged

mattseymour

  • Guest
Re: New host crashes out
« Reply #1 on: June 10, 2018, 11:40:23 AM »

In this test environment the host doesn't work. I tried an older version of host and gui and they're fine.

The new host will start but it doesn't do any processing and if prodded enough will bomb out.

After a bit of stopping and starting of the host it will eventually start working, but the DSP load is high, 49% vs 21% on the older version. But it isn't stable.
« Last Edit: June 10, 2018, 11:43:03 AM by mattseymour »
Logged

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 956
    • View Profile
Re: New host crashes out
« Reply #2 on: June 12, 2018, 12:04:50 AM »

Hi Matt,

Hmm, this seems very strange, as there haven't been any real major mods to the basic host framework.  Have you tried clicking the button to Reset the Host Config?  Let's see what that does.

Also, if you hold SHIFT while starting the host, it will not automatically start the engine.  Might be helpful when debugging.

Bob
Logged

mattseymour

  • Guest
Re: New host crashes out
« Reply #3 on: June 12, 2018, 03:56:02 AM »

I'll have another play with it this evening. I'd never use the host on this system, but it could be a sign of something amiss with the latest windows 10 builds.
Logged